My biggest blunder: Stuck ALT Key for over 2 years in Windows

Did it ever happen to you that you are looking for your glasses while wearing them? Or maybe the phone? And it feels so stupid when we realize it. Guess what, these are nothing in front of the facepalm moment I faced.Windows 10 desktop

The Story: once upon a time I used Microsoft Windows

Remember when the first time Windows 10 released? I was one of the first to use it. Using the RTM version. I used it for tasks like photo editing etc. One day, suddenly the keyboard stopped working. No amount of what I did could solve it.

I slowly leaned towards Linux, rarely went to Windows and when I did go, It didn’t work. I couldn’t enter the password. And for some weird glitch, I couldn’t open the Ease of Access menu either to fire up the On Screen keyboard.

One day, I formatted the windows drive to use it as a file storage partition. Used it for over a year, until recently, I started the need for Windows. As much as I love Linux/UNIX, there is no question that Software developers don’t develop for Linux. In pro video editors, only LightWorks and DaVinci Resolve has Linux editions but  DVR refuses to run on my hardware, and LightWorks crashes/stutters and LightWorks is probably more advanced than my liking.

No. Not windows. It's Linux

My Linux Journey so far

I have edited pretty good on Kdenlive, but more than its limitations, its crashes killed my patience. Then, I got interested in 2D Animation, bad luck! While, 10 years down the road, Synfig Studio, if actively worked on, would be a great tool, but as of now, without a graphics tablet, it’s lame.

Then, my interest began peaking in audio. Because, audio is the biggest contributor in a video. and here, I was modestly lucky. Linux has LMMS and Ardour. And while Ardour can use samples efficiently, it’s midi capabilities disappointed me. But LMMS shines there. LMMS got you covered in almost everything you imagine. The only caveat? You gotta design synths.

Yes, I know ZynAddSubFx, Helm, amsynth, alsa modular synth, samplv1 can make almost any sound out there. But SERUM, MASSIVE and NEXUS has some serious shit up their sleeve. (All of them work, but none of them get saved)

And the above mentioned are pretty much the only quality synths. The rest is all experiments by universities or students. They either sound like trash or are not designed for sound designing, rather they were built for synth designing, i.e. practice lessons.

LMMS on Linux
LMMS can be quite powerful.

The Rescue: LMMS can load Windows VSTs

The Linux MultiMedia Studio can go big! I tell ya! Its only 1.2.0-rc5 as of now, but it has got a great piano roll, song editor and mixer.

And with the ability of it to load Windows VSTs (Synth1, TAL NoiseMaker works, everything else is a mixed story. Massive and Nexus works but can’t save settings) it is equipped to produce audio.

I tell ya, once it gets its bassline editor fixed and automation a little streamlined. (only the interface, its engine is fantastic), maybe LV2 FX support (Lv2 has great fx),  better Linux VST Support and a little more polish in its audio sampler, it can be used to produce music. One thing it got sorted is the piano roll.

Yep! I built it
I have designed this poster using Inkscape on Linux

Graphic Design on Linux: 4 stars

With GIMP (image manipulation), Krita (raster arts), and Inkscape (Vector drawing), not to mention UFRaw and Darktable, and the infamous ImageMagick suite, you can actually make sensible stuff that looks professional. Sure, GIMP doesn’t have healing brush, but I am good at clone stamping. So, most of the things you can do in Photoshop, GIMP+Krita+Inkscape can get it done.

RAW Image handling is no big deal, UFRaw and Darktable can get process RAW, enough said.

KDenlive is powerful, but crashes!
Modest number of tools. But they don’t all work well always. The greatest pro is cutting, it has the best cutting tool I’ve seen

Video Editing Sucked and I kept getting Video projects

As much as I want to be a codestar, I can’t get people to pay money to do hack-y stuff (because that’s where the fun lies). So, my dream of shredding with a QWERTY keyboard might not fulfil soon, but thanks to Kdenlive constraints, I got good at composition. Because I can’t fix in post, so, I kept taking better footage in-camera. I can’t add VFX, so I supplemented VFX with AFX (AFX can have a deeper engagement with user than VFX)

So, I had to install Windows to get at least Filmora running. my old b980 probably can’t handle premiere pro.

Windows 10

The day came when I formatted /dev/sda5 to ntfs and /dev/sda1 to ntfs and added a boot flag. Used unetbootin to load Windows on a USB and BAM!

It didn’t work. my old acer bios can’t take it. Used WinUSB, ended with Exit for 256. WoeUSB: Same.

I just couldn’t get the Flash drive to work. I didn’t want to install grub on it, I wanted to have a real solution. Not a grub hack. I could always keep the disk connected, update-grub2 && reboot now and it would’ve worked.

And off I came to know ms-sys, a fantastic bootloader to load Windows bootloader (probably /nt60) from Linux.

I compiled it. Installed it and it booted. I will write a tutorial on how to use ms-sys to make a Windows USB Bootable drive. It might just be simpler than from windows itself.

Getting Things Ready for installing Windows..

And I was pretty excited, no matter how lame  windows is, it feels exciting to install it. Although, you feel like you’re inside a dressing room and feel like there’s a hidden camera, and you know there’s a hidden camera, but it’s the most popular dressing room around. So, you feel excited

As I was presented with the option to enter username and password. I couldn’t.

There was no way in hell it could happen. I could boot Linux with no issues, I could go into BIOS and do everything, but I couldn’t enter my username in Windows.

So, what was it?? Reinstall

Same problem. Repeated.

Yet another reinstall

Nothing changed.

Did I ever tell you the definition of insanity?

Its doing the exact same fucking thing, over and over and over again! Expecting shit to change. So, I thought, the Image might have been corrupted. I didn’t have its checksum so, I got another image from my friend.

The New Winshit installer speaks!

At least I could use my voice to enter the username. I used “pencil” because I know voice assistants have a tendency to mess my name “Sohan”. Along the way, I tried to enter the password with the keyboard! And it still failed.

ba dum tss

The Indian way of repair: banging

Trust me, we have a way to repair everything. Bang it. If a remote doesn’t work. We bang it, it works. I have once kicked my bicycle in frustration and the chain got into a situation where I could ride it.

I tried it. Not out of utility, but out of frustration. And it prompted “Are you sure to quit installation”

There’s no way in hell I banged the Alt key. My fist was in the upper region. I smelled something.

I pressed the F4 key! “Are you sure to quit installation?”

WHAAAT!

I checked my laptop’s internal keyboard (I don’t use it at all. as I have a dysfunctional display and some keys don’t work), popped out both the Alt and AltGr keys and did some voodoo magic and BAM!!

Typing started working (in Windows)

All along, for 2 years! the Alt key was held down. for over 2 years, my laptop’s Alt key was pressed.

Why Linux worked?

Because Linux is smart, it doesn’t work if you press Alt in a usb and F4 in a PS2 keyboard. Linux is a multi user multi input system, so such isolation is nothing different.

But what messed me was GRUB. For over 2 years, I had to use a special version of GRUB. 2.00-19ubuntu2.

Apparently, a user in an ubuntu forum said that, that version “does not have the bug” where we can use the keyboard.

And I believed it. I have re-checked it. It actually has a bug where, if we manually use “usb_keyboard” as the TERMINAL_INPUT, it doesn’t respond to PS2 keyboards at all. This bug wasn’t in other versions and so, none of them worked.

It was actually a nice “feature”.

Apparently, that dude probably has a key stuck somewhere. I will check with him later. As his fix solved my problem almost everytime.

So, how is Windows?

Still sucks big time. Not the apps. Adobe Suite, Filmora and all apps, they rock. Not Windows! It still sucks.

What I hate is, I came to see <1GB as low, 1-1.5GB as medium and >2.5GB RAM usage as high. And in Windows, that’s where the it starts, 1.2GB is like the least.

All these, with no extra OS features.

Except a key feature. Viruses!

Recent Posts

Recent Comments

Archives

Categories

Meta

Be First to Comment

    Share your valuable feedback